事实上,报这个错误的时候,机子上是装了jdk的,配置的也没问题。问题出在哪呢?这其实是MySQL的一个Bug,它会去注册表里找版本为1.5的JRE。但是如果你的机子上装的是1.6或1.7或更高版本,注册表里是不会有1.5版本的JRE的任何痕迹。那这时候MySQL就自认为任务完成,给你报错了。

解决办法:到注册表[HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Runtime Environment/]目录下,手动建立项,取名1.5,在1.5中新建字符串值,取名为RuntimeLib,将值设为C:\Program Files\Java\jre6\bin\client\jvm.dll。

注意,如果你的MySQL Migration Tool是32位,即x86,那你在注册表中设置的路径也要是32位JRE的路径,不能是64位JRE的路径。

Copyright © 2014-2017 it689.com (京ICP备12032795号-2) 版权所有 Power by IT689